Polaris ATV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I just purchased a sportsman 850 sage green.
When I place the unit in reverse or H/L then slowly apply throttle it has some lag then all of a sudden , go!

If you hit the throttle quick after placing in Reverse or H/L it grabs hard after a very short hesitation before it grabs the gear.
Is this normal?
 

·
Registered
Joined
·
59 Posts
Mines the same way, it's been like that since I bought it. 2014 850xp sportsman.
 

·
Registered
Joined
·
993 Posts
Yes normal operation of the CVT tranny and clutches, you have to get the rpm's up to engage the belt.
 

·
Registered
Joined
·
1,919 Posts
I just purchased a sportsman 850 sage green.
When I place the unit in reverse or H/L then slowly apply throttle it has some lag then all of a sudden , go!

If you hit the throttle quick after placing in Reverse or H/L it grabs hard after a very short hesitation before it grabs the gear.
Is this normal?
The manual says not to increase throttle slowly, instead use a more forceful push on throttle to get the clutches to grab and hold on tight. This avoids excessive clutch rubbing and related heat.

Now if you're going to travel slowly, less than 10 mph, you should use Low for the same reasons. Luck. :cowboy:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Yea I read the manual where it stated about using low range for pulling and speeds below 7 mph. I missed the part about non light throttle use. Called to ask my service dept guy today, he said what you said.:veryhappy:
 

·
Registered
Joined
·
1,656 Posts
Get a QSC clutch kit and you will have all the instant throttle response you will need.
 
1 - 6 of 6 Posts
Top