Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
95 250 trail blazer,
just acquired, been in a barn for 15 yrs,
belonged to a college, very seldom used.
recoil starter cord is hanging out,
I removed the assembly got it to work on the bench, reinstalled.
and 2 pulls later same thing, won 't rewind.
removed and it all appears ok ,not broken,
how do you get to the spring?
and is there a common problem with these?
thanks!
 

·
Registered
Joined
·
1,891 Posts
did you spray a little penetrating oil in there..after 15 years there may be a bit of rust....I believe there is a tiny spring in there besides the main coiled spring....might be to return the dog that catches fly wheel per say...could be rusted done...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
yes, I cleaned and oiled the insides, and wound the unit backwards to create more spring tension,
when it rewinds, it catches and pulls thru good,
just will not rewind,
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
5,753 Posts
Maybe you unwound it a little? Our the spring could be broken. It's under the plastic disc the rope winds into. Should just be a nut in the center to remove and it all lifts out. Pay close attention to how all the parts are stacked and connected. And be careful of the spring isn't broken as they can come flying out in a big messy coil.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I think something is amiss!(broken)

as it will work, then NOT work,
how do you get that big washer/ nut loose?
is it reverse thread?
someone has had it apart before, as I see punch
marks on it,
 

·
Registered
Joined
·
39 Posts
There is a metal cup that the main spring hooks on. It spins on a aluminum shaft. This can stick after asitting. I put a bit of lube bio n mine the last time I rebuilt it seemed to solve this problem for me. Hope this Helps.
 
1 - 7 of 7 Posts
Top