Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought new a 2019 Sportsman 450 @ 6 months old had a check engine lite come on. I'm unable to get to the diagnostic code screen on the instrument cluster as per owners manual. I had changed Oil and filter prior to this issue. It still runs good. I can clear the lite by multiple pressing of the mode and arrow buttons. But lite comes back on after a while. Dealer wants $150 to inspect it. As now it's not covered under warranty. Any assistance would be appreciated.
 

·
Moderator
Joined
·
10,595 Posts
That may be your only option if you can't pull the trouble codes. They can hook it up to a laptop and use the Polaris Digital Wrench software to diagnose the problem.
 

·
Premium Member
Joined
·
9,773 Posts
How does the manual instruct you to pull the codes??
 

·
Registered
Joined
·
18 Posts
I'm new too, but is it the CEL or the maintenance light? Did you reset your maintenance hours after the oil change?

Sorry if I'm way off base, just a thought as I didn't know this had to be done at first either.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
the manual says to toggle thru the menu screen and get to the Diagnose screen. Well that doesn't work. can't find that screen and trying many times.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I'm new too, but is it the CEL or the maintenance light? Did you reset your maintenance hours after the oil change?

Sorry if I'm way off base, just a thought as I didn't know this had to be done at first either.
Hi no it's the CEL I already reset the maintenance lite after changing the Oil.
 
1 - 7 of 7 Posts
Top