Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a new 2012 Sportsman 550. Currently has 7 hours on it. It's been 15 years since I enjoyed riding an atv. Took it out on a good ride only once so far and on short 5 - 15 minute rides around the neighborhood. I keep it garaged and toyed with it today for a little bit. Tonight I started it up in my garage to park it in it's designated area and noticed my instrument cluster is RED. I cannot find anything about this in the Owner's Manual or online about this. Is this my first issue with the atv or is it some setting option that was accidentally turned on?
 

·
Registered
Joined
·
255 Posts
Nothing wrong....that's the normal background lighting for it. It's on all the time, just can't see it in the daylight. I was riding a trail several years ago, when we first got our Model T, and got into a really shady, dark area on the trail. I saw the red for the first time and like you, thought I had a problem.
 

·
Registered
Joined
·
1,181 Posts
Not an issue at all, it is normal.

Red instrumentation goes back to the early marine and ship days. The color red is used to prevent your eyes from becoming night blind. If you look at another color light then look back at the trail at night, it takes a few seconds for your eyes to readjust to the darkness. Like walking from a well lit room into an unlit room. With red lights the adjustment period is very minimal or non existent..
 
1 - 5 of 5 Posts
Top