Polaris ATV Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I purchased a 2019 Sportsman 570 EPS brand new and have been riding it for a few months. I have problems with it that I have no clue what is causing them.

Basically the machine is terribly unstable. Starting at about 20 mph the machine will feel like it is lurching sideways when hitting any slight bump or even small steering corrections. This problem is so bad that it has almost completely ruined my enjoyment of riding.

I have no idea at all what is causing it. I tried adjusting the air in the tires, changed the suspension firmness, gave it a steering alignment, nothing has helped at all. My machine is completely stock from the factory. I can't afford to just ditch the machine and get something else. Does anyone have any suggestions of what this might be? I have not experienced anything like this in other sportsmans that my friends ride (Although they all have the 850 SPs,) and I have had others ride mine and complain about the same thing.

Can anyone think of what might do this? It really sucks having a new ATV that I hate.

-Matt
 

·
Premium Member
Joined
·
9,833 Posts
Can you post up a vid.
 

·
Premium Member
Joined
·
1,556 Posts
Where did you set your toe in setting at?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hi everyone. I havent brought my atv in to the dealer yet. I have not done so because the dealer doesn't have a place to ride it, and I can't point to him what needs to be fixed. I do not have a video to show people because the ATV feels more erratic than it would look. It doesn't actually swerve much, you just feel its weight shifting more than it should when riding over any sort of rough terrain. And lastly I believe I set it for 1/4 inch toe out. I believe that was what was in the manual. I tested it by taking it to a smooth road after doing my adjustments, and it handled ok. The problems it seems to have are when you are navigating over rougher terrain it feels like its weight shifts a lot and you feel like you need to really hang on.
 

·
Registered
Joined
·
40 Posts
Something is seriously wrong with your machine. I can do damn near 70mph accross desert whoops and mine feels rock steady... I would cease further riding until a pro can look at your machine before it kills you.
 

·
Premium Member
Joined
·
1,556 Posts
I believe your toe and should be set at 1/8 to 1/4 IN not out.

I stand corrected it’s towed out...
 

·
Premium Member
Joined
·
9,833 Posts
Yup all I can say is AGREED^^^^^^^^^^^^^!!!!!!!!!

Something's got to be up. Polaris has to be the most stable machines in the market.
 

·
Premium Member
Joined
·
9,833 Posts
correct "TOE" is set OUT!! opposite of an automobile.
 

·
Registered
Joined
·
28 Posts
Does it happen when in 4wd or all the time. Mine has an issue when in 4wd that the eps is intermittent
 

·
Registered
Joined
·
142 Posts
You stated that you adjusted the tire pressure but you did not state what you have the tires set at. I run mine at 6 PSI and have no issues. If you have over inflated tires it could be causing your issue.
 
1 - 18 of 18 Posts
Top