Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys and gals names Dru new to the atv game.

Just picked up a 92 (I think) trail boss 350l it needs some love but it starts and drives and the price was perfect.

Have a few questions:
How do you set the idle? It won't idle at all.

How long should a tank of oil last? It's has the tank in the front under the head light it's near full and I have rode for about hour hour and a half and it doesn't seem to be using any. But it does smoke like a two stroke should. Any way I can check to see if the oil pumps working correct ?

And ever since I put the battery in it won't start by pull start anymore and dies when I put it in reverse but prior to that would start one or two pulls and revered no issue.

Sorry for all the newbie questions

Thanks Dru!
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
4 Posts
To check the oil, I would pull the oil line off the side of the intake, start it up for a bit and see if it spits out oil.

Could adding the battery have caused a weak spark somehow? All the same electrical and mechanical parts are used for electric and pull start from the flywheel on, could be it doesn't generate enough spark when pulled and then when put under load it kills!? Just a thought.
 

·
Registered
Joined
·
21 Posts
sounds like i should do the same with my 91. I picked mine up and rode it for about 40 min and parked it in the garage. Went to ride it about a hr later and it took forever to start and barely ran in reverse then died shortly after and wont start.

It would be nice to know exactly how to set a carb back to stock specs.
 
1 - 4 of 4 Posts
Top