Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I've been through hell with this quad. It was in perfect condition, I went to start it and all I heard was huge knocks. This was back in October. So it ended up being a one way starter clutch, popped a new one in, started right up, but sounded like shit. The timing chain was smacking around so I put a new one in, but now it won't start back up! The quad isn't getting compression and I have no idea why. If anyone knows or may have a clue, PLEASE HELP!!
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
Not trying to be a smartass, but we are in the Polaris Predator section hahahaha. But I figured it out. It needs a new cam. Now I have a pretty much rebuilt engine in it over the past year
 

·
Registered
Joined
·
7,464 Posts
Not trying to be a smartass, but we are in the Polaris Predator section hahahaha.
Not trying to be a smartass, but you'd be amazed at how many people don't post in the propper area's on the forumo -or- at how many people reading the posts in "active topics" page don't watch which section they are reading from hahahaha! :D

It needs a new cam. Now I have a pretty much rebuilt engine in it over the past year
Glad to hear you got it figured out! My thought when I first read this yesterday, was the timing was off also. :fing02:
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
Not trying to be a smartass, but we are in the Polaris Predator section hahahaha.
Not trying to be a smartass, but you'd be amazed at how many people don't post in the propper area's on the forumo -or- at how many people reading the posts in "active topics" page don't watch which section they are reading from hahahaha! :D

It needs a new cam. Now I have a pretty much rebuilt engine in it over the past year
Glad to hear you got it figured out! My thought when I first read this yesterday, was the timing was off also. :fing02:
Ya I know what you mean! Hahaha
 

·
Registered
Joined
·
1,103 Posts
Not trying to be a smartass, but we are in the Polaris Predator section hahahaha.
Not trying to be a smartass, but you'd be amazed at how many people don't post in the propper area's on the forumo -or- at how many people reading the posts in "active topics" page don't watch which section they are reading from hahahaha! :D

It needs a new cam. Now I have a pretty much rebuilt engine in it over the past year
Glad to hear you got it figured out! My thought when I first read this yesterday, was the timing was off also. :fing02:
LOL Classic case of what's bolded up there!

Anyway, glad to hear you got it figured out!
 
1 - 7 of 7 Posts
Top