Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2006 Sportsman 700 EFI. Replaced fuel pump. Hoses in fuel pump assembly trashed, probably due to ethanol in our gasoline--another story. After putting it back together, it started and ran great with good power. However, the Check engine light comes on. I can reset by restarting, but inevitably comes on again. I have no fuel quantity indication any more on the speedo display. I ran a diagnostic and it reported codes 41 (Air temp senser: open or short circuit to ECU) and 45 (Barometric pressure sensor: circuit low input). Check engine/codes 41 & 45/no fuel quantity indicator--any thing these all have in commor? Have checked almost everything I can find thus far on the forum but can't find a smokin' gun.
 

·
Registered
Joined
·
1,963 Posts
These codes are usually the T-BAP connector. The gauge issue might be a separate issue.

Only The Best
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
4,243 Posts
Check wiring at t-bap sensor , there are heavy duty kits on e-bay to replace wiring, as for fuel gauge, reach in tank with wire and pull float up, see if it reads full, if it does , float is bad, getting full of gas and sinking to bottom.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Nofuel indication

Thanks Treacherous, et al. I will be ringing out the T-BAP harness today. If I have any success, will report it asap.
 
1 - 6 of 6 Posts
Top