Polaris ATV Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Is there any other "Sensors" or "Switches" that makes the ECM (#4012616 ECU) spit out ground from pin -6- (E70)???
A few months back I started having problems starting my Sportsman 850 xp eps 2010.
When turning the key to "Start" it would go "Click, Click, Click" but nothing else... but not every time... and it would finally start...
Last week-end it didn't want to start at all, so I started investigating the problem.
I downloaded the Wiring diagram and found out that the E70 (BN/WH) wire comming from the "ECM" and going to the "Start Selenoid Relay" was not giving out "Ground" to "Start Selenoid Relay". So I used a jumper wire and conneted it to the chassis from the E70 pin of the "Start Selenoid Relay" and as soon as I turned the key, it started.

So once again, my question is; is there any other "Sensors" or "Switches" that makes the ECM (#4012616 ECU) spit out ground from pin -6- (E70) or is it just a part of the "ECM" that just died on me?

I would really appreciate a if one can help with a valid, straight to the point, technical answer. Or at least point me in the right direction.

Thank you for any help.

Patrick Rivard
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I used a jumper wire and connected the E70 pin of the "Start Solenoid Relay"
to the chassis.
The little "Alligator" clip Jumper wire is still there under the front rack.
I never found any other remedy... No one has even ever replied to this post...
Even my dealer did not know how to repair aside of the complete replacement of the ECM...$$$

Hope this helps you out.
 

·
Registered
Joined
·
2 Posts
Ecm

Thanks for the quick response. I did that and it worked. Must be its continued to work for you. I wondered if an ECM reflash would help but maybe I wont worry about it. Did you just leave the cut end from pin 70 open and taped off?
 

·
Registered
Joined
·
10 Posts
Is there any other "Sensors" or "Switches" that makes the ECM (#4012616 ECU) spit out ground from pin -6- (E70)???
A few months back I started having problems starting my Sportsman 850 xp eps 2010.
When turning the key to "Start" it would go "Click, Click, Click" but nothing else... but not every time... and it would finally start...
Last week-end it didn't want to start at all, so I started investigating the problem.
I downloaded the Wiring diagram and found out that the E70 (BN/WH) wire comming from the "ECM" and going to the "Start Selenoid Relay" was not giving out "Ground" to "Start Selenoid Relay". So I used a jumper wire and conneted it to the chassis from the E70 pin of the "Start Selenoid Relay" and as soon as I turned the key, it started.

So once again, my question is; is there any other "Sensors" or "Switches" that makes the ECM (#4012616 ECU) spit out ground from pin -6- (E70) or is it just a part of the "ECM" that just died on me?

I would really appreciate a if one can help with a valid, straight to the point, technical answer. Or at least point me in the right direction.

Thank you for any help.

Patrick Rivard
Hello! Have this fix solved the starting klick forever? No other problems after grounding pin 70 on ecu to frame?
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
10,135 Posts
Font Line Window Pattern Automotive exterior
to the forum
Ball Automotive lighting Vehicle registration plate Font Gas
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
10,135 Posts
Hello! Have this fix solved the starting klick forever? No other problems after grounding pin 70 on ecu to frame?
The ground to that circut comes from the brake light circut when applied at start up.
 

·
Registered
Joined
·
10 Posts
But the brakelight lights up when pulling the handbrake.. and the brakelight is working. But we have no brakelight on the footpedal. My frend says he never had to pull the brake to start it on P or N gear..
This is a 2009 model. Isn’t it the later models one must pull the brake to starter to crank?
In all gears.
 
1 - 13 of 13 Posts
Top