Polaris ATV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I just got a 2005 330 magnum and I have no spark I have checked the throttle slack and the contacts are touching disconnected the ground from the Cdi no spark where do I go next. Thanks in advance
 

·
Administrator
Joined
·
18,800 Posts
I just got a 2005 330 magnum and I have no spark I have checked the throttle slack and the contacts are touching disconnected the ground from the Cdi no spark where do I go next. Thanks in advance
Unplug the black wire from the CDI box and check for spark - if still none then it is a bad connection or a failed ignition component
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
I unplugged the black wire from the cdi and no spark tried checking ohms on trigger coil but keep getting 541 which seems impossible machine has been setting for 2 years going to get a new plug tomorrow is there another way to check the trigger coil
 

·
Administrator
Joined
·
18,800 Posts
Ohms is about right - book indicates 522 ohms on a new coil and it changes with temperature and age.

Another way to check? Yes, check the peak voltage generated while cranking the engine - should be 3 to 5 volts PEAK.

Schematic Font Parallel Engineering Pattern


Font Rectangle Parallel Number Screenshot
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Okay thanks I’ll check the peak voltage in the morning and I’m guessing it’s from the same wires if that checks ok what would be the next thing to go after
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
Thanks that’s what I was thinking would you by chance have a P/N for it also any special instructions on changing it thanks for the help
 

·
Administrator
Joined
·
18,800 Posts
Pulse coil is part of the stator - part number is 3089275 and is NLA - have to shop Ebay, Facefook or Damnamazon

White Font Circle Auto part Art
 
1 - 9 of 9 Posts
Top