Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have a 2001 sportsman 500 currently i have no speedo or odometer, my four wheel drive will also not turn on and i have yet to hear the fan kick on since the problem started..?????????? Was wonder if anyone would happen to know what my issue is and how i can resolve it. I have heard that it could maybe be the the hall effect sensor but i dont think it would effect anything but the speedo so i am open to suggestions........
 

·
Registered
Joined
·
3 Posts
my speedo and on demand switch stopped working. the dealer says probably a ground wire off somewhere. havent had time to look yet.
 

·
Registered
Joined
·
900 Posts
Why are starting another thread for the same issue?

If you didn't like my advice, wait a little and someone else will chime in with another idea....

Kevin
 

·
Registered
Joined
·
213 Posts
i have a 2001 sportsman 500 currently i have no speedo or odometer, my four wheel drive will also not turn on and i have yet to hear the fan kick on since the problem started..?????????? Was wonder if anyone would happen to know what my issue is and how i can resolve it. I have heard that it could maybe be the the hall effect sensor but i dont think it would effect anything but the speedo so i am open to suggestions........
Hi,I had the exact same problem after I replaced my pod headlight and found out it was bad wiring inside pod area. After the wires were fixed, everything works fine after that. Something tells me you may have a loose or broken wire inside your pod. Check it out in the and see what you can find. Good luck...
 
1 - 4 of 4 Posts
Top