Polaris ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2006 sportsman 500. While riding it i get a constant clicking noise coming from the right side. so I change the bendix and the noise went away then came back after half an hour. Has anyone else had this problem before. Any help would be appreciated thanks.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Bought a new starter

I bought a new starter and the noise went away for an hour or so, then came back. WTF !! What else can I do? Any help would be much appreciated.
 

·
Registered
Joined
·
593 Posts
Just a thought, you bendix shouldn't be getting power without turning the key, could you have a short, ignition switch issue or solenoid issue. If you could rig up some way to see if power is getting to the bendix while riding, like some type of 12V test light connected to ground and the positive on the bendix, just a wierd idea!
 

·
Registered
Joined
·
13 Posts
I have the same problem sounds like a rattle that increases with rpms but not at idle. also just realized that the pull cord just pulled out and didnt retract could all this be related?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Well it looks like I fixed my bendix problem. I had to get two new bushings. one on the recoil cover and one against the engine side. I had to buy a bushing removal tool from harbor freight, that got the bushings out pretty easily. No noise coming from the recoil cover on my last 3 hour ride.
 

·
Registered
Joined
·
497 Posts
Well it looks like I fixed my bendix problem. I had to get two new bushings. one on the recoil cover and one against the engine side. I had to buy a bushing removal tool from harbor freight, that got the bushings out pretty easily. No noise coming from the recoil cover on my last 3 hour ride.
Do you have the number for the Harbor Freight bushing removal tool? I did a search on there site and can't find one.
Thanks
 
1 - 11 of 11 Posts
Top