Polaris ATV Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
650 Posts
Discussion Starter #1
After 3 week's in the shop because Polaris shipped one wrong length axle I finally picked my XP up yesterday. No more clicking noise coming from the rear and it run's even better then before. Front end look's OK but mechanic will go ahead and change out the knuckles and ball joint's later when they come in just as a precaution. Also had them put on wheel spacer's in the rear for more clearance for the XTR's vs. the swaybar. After 6 inches of rain yesterday we have a lot of mud to go try it in later!! :D
 

·
Registered
Joined
·
650 Posts
Discussion Starter #2
Lot's of room now!
 

·
Registered
Joined
·
1,189 Posts
good to hear your back on the trails paw paw. were you still under warrenty?
 

·
Registered
Joined
·
650 Posts
Discussion Starter #4
good to hear your back on the trails paw paw. were you still under warrenty?
Still under warranty plus I have the extended warranty which kick's in shortly.
 

·
Registered
Joined
·
21 Posts
I also have an 09 550 with clicking in the rear axles at 71 hrs, my buddy has same bike and had to replace his at62hrs, wondering how common this is and weather i should purchase extended waranty to keep it running also cooling fan stopped working temperarily any ideas? thanks
 

·
Registered
Joined
·
563 Posts
I would strongly recommend an extended warranty for the 550XP.My 550 is in the shop for a rear cv problem(clicking)and a couple of other things also.And like PawPaw said,the dealer has had it for 3 weeks at least.
 

·
Registered
Joined
·
650 Posts
Discussion Starter #7
I also have an 09 550 with clicking in the rear axles at 71 hrs, my buddy has same bike and had to replace his at62hrs, wondering how common this is and weather i should purchase extended waranty to keep it running also cooling fan stopped working temperarily any ideas? thanks
I'm glad I went with the extended warranty you may want to look into it. The clicking sound is rather common on the new XP's, they changed out both of my axles and it's OK now.
 

·
Registered
Joined
·
1,149 Posts
Ummmm. Did the dealer say what the issues with the axles are when you got them replaced?
 

·
Registered
Joined
·
650 Posts
Discussion Starter #9
Ummmm. Did the dealer say what the issues with the axles are when you got them replaced?
They said it was the bearings making noise in the housing (too much slack). New assy. working fine now.
 

·
Registered
Joined
·
20 Posts
I have to ask, I also have an 09 xp 550 and have already mentioned that mine also clicks at different speeds but more when I let off gas or going down hill. Is that what has been happening to any of you? I had mine in the shop and they replaced the rs axle they said they think that was the problem. But I have also read on this forum that the hill descent control makes a plastic sort of clicking sound in the rear is this true? Just need to know if I need to bring mine back in for something else cause mine still makes a sporatic clicking sound in rear, but its not metal sounding more of a plastic clicking noise..
 

·
Registered
Joined
·
563 Posts
I had trouble with my ADC making a real bad metal to metal grinding noise but not coming from the rear.It was more from the front center area.I also had a right rear cv/axle problem that made the clicking noise so it got a new axle.
 

·
Registered
Joined
·
650 Posts
Discussion Starter #12
I have to ask, I also have an 09 xp 550 and have already mentioned that mine also clicks at different speeds but more when I let off gas or going down hill. Is that what has been happening to any of you? I had mine in the shop and they replaced the rs axle they said they think that was the problem. But I have also read on this forum that the hill descent control makes a plastic sort of clicking sound in the rear is this true? Just need to know if I need to bring mine back in for something else cause mine still makes a sporatic clicking sound in rear, but its not metal sounding more of a plastic clicking noise..
Mine started clicking upon acceleration and turned out to be metal on plastic.
 

·
Registered
Joined
·
20 Posts
I guess I have one last question then. Did this clicking noise that so many of us have experienced happen all the time or just occasionally and if so when you accelerate or brake or brake the tires loose or what? Thanks
 

·
Registered
Joined
·
563 Posts
I first noticed the clicking noise when I was backing up.I didn't ride after I knew it was a cv/axle except to put it on the trailer and it did click a little while turning.
 

·
Registered
Joined
·
20 Posts
I first noticed the clicking noise when I was backing up.I didn't ride after I knew it was a cv/axle except to put it on the trailer and it did click a little while turning.
Yup does sound like mine to, but the sad part of it is I have already taken it in and they told me after a 3 week wait for the part that it was the rs shaft and they replaced it! BUT it still makes that noise maybe not as frequently but still i hear it every so often. I am startin to wonder if matbe its me being to picky with every little sound..

So when your guys machines were fixed the noise has went away and stayed away or do you still hear it!
 

·
Registered
Joined
·
563 Posts
I dont hear it now.Your left side might be bad also.If you think its a cv/axle problem,then take it back and have them check it.
 
1 - 17 of 17 Posts
Top