Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
5.jpg

20130902_194842.jpg I have a 2001 325 Polaris trail boss .

When I bought it I was told its just a carb problem.Idle low when revved up it bogged down.I brought it home it home cleaned carb started back up ,still revved on low so I let it idle and warm up then started revving and playing with throttle.It started backfiring and spiting and sputtering,and exhaust got cherry red,if you spit on it it would boil.From reading I think its the exhaust lobe.Here are some pics tell me what you think. Also I don't know if someone tried fixing before and didn't line things up right.
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter #2
2001 trail boss325

Here are some updated pics of rocker arms.also i was wondering the marks on the sprocket are lined up right,and there is a silver or gold link in the chain does this mean any thing.ty again
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for no help............

Tried the sight. Searched all Forum .Then maid a post with pics. I got nothing.but i did fix machine. after changing lobes and putting together i had to pull throttle cord about 30 times to fill carberator float with fue.l Then on then on 31 pull started right up.Wish I Had electric start.
 

·
Registered
Joined
·
5,753 Posts
Sorry. I didn't see this till now our I would have tried to help. To much on here to see it all sometimes. Glad you figured it out. Your fuel pump may be a little weak with that many pulls to fill the carb. A little air pressure in the gas tank next time will push the fuel through and save you about 25 pulls.
 
1 - 4 of 4 Posts
Top