Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter #1
i have been having a problem with my quad running crappy sometimes dieing for a split second then finally yesterday plowing snow it completely died n i had to get my yammy to pull it into my yard and started working on it find when i wiggle the wires to the forward of the two plugs it will make it work and run again and if i wiggle them just right it will run and idle perfectly fine
so this morning i cleaned the plugs on both sides with clr and it helped but still same problem

my assumtion is that the wires to the kill switch are the farword of the two plugs and witchever conectors are to the kill switch the piece in the plug that "springs" sort of to make the connection tight is corroded and siezed up making the connection loose all the time\

basicaly all i want to know is if this all seams possible witch wires in the harness go to the kill switch and couldnt i just cut them down in the pod and soldier connect n heat shink them together to elliminate the kill switch all together i never use it and from what ive bean reading it seams to create a lot of problems..........anby help would be appretiated0
 

·
Registered
Joined
·
434 Posts
Discussion Starter #3
i need to know witch wires go to the kill switch any ideas?
 

·
Registered
Joined
·
526 Posts
Polaris Sportsman 500 Service Manual | eBay

In the event you have not picked up a copy of the Polaris service manual for doing your own upkeep here are some options. I got ours off Ebay and in paper it was about $50 I think but the PDF option is next to nothing and you get it NOW I read. I have not looked at them for our model but they are in the back of the Polaris manual.
 

·
Registered
Joined
·
434 Posts
Discussion Starter #5
thank you i downloaded a service manual and got a little insight from that and added some bare copper wire in the plug holes to make the pins on the switch side tighter really helped alot
 
1 - 5 of 5 Posts
Top