Polaris ATV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
1,181 Posts
hi my 2010 polaris sportsman 500. when i give it gas it goes straight to top gear and just dies also the 4wd wont disengage what could be wrong
What do you mean by it goes straight to top gear?
 

·
Registered
Joined
·
2,980 Posts
Say there is 5 gears as soon as you give it gas its goes straight to the top one and kills the bike[/QUOTE

A 2010 Sportsman 500 doesn't have 5 gears. It has low range and high range and reverse. It has a CVT not a geared transmission
 

·
Registered
Joined
·
1,181 Posts
I think you may have misdiagnosed the problem. High and low are selected manually on your machine. Can you give it throttle in neutral or park with no problems? Does the machine move or is it drivable when in high or low? Will it move in reverse?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
The bike revs up fine whem in neutral or park but dosent in high low or reverse. as soon as you give it gas it feels like it misses the first couple of gears .it all started after the belt snapped .
 

·
Moderator
Joined
·
13,769 Posts
It don't have any "gears" as you call them. If it blew a belt it probably has pieces of the old belt wrapped up in one or both the clutches jamming it up. You'll need to take the cover off and clean the clutches. They may even need to be disassembled to get the old belt cords out.
 

·
Registered
Joined
·
2,980 Posts
Took cover off and the belt anf then the secondary clutch and i think the clutch buttons is worn out could that be the problem
Yes, most definitely.....Talk to ridinagain
 
1 - 14 of 14 Posts
Top