Polaris ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello!
I noticed today that my beltcover and housing moves when i pull it, up and down 2-3 cm, is this normal? all bolts are thight, and the whole housing moves not just the cover.. And today i drove in deep water and no water leaks in to the housing...The atv rides fine, no strange sound...
Any suggestions?
 

·
Registered
Joined
·
2,352 Posts
They all do that.
The inside cover,which mounts against the engine and transmission, is plastic as well, so you will get some flex. Enjoy
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
434 Posts
does it leak? try not to pry on it to excessively, it can cause your inner seals to leak(between motor and cover)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
ok thank you. No it does not leak, but yesterday when i put my hand on the cover it was really hot?? or is it time to replace the belt? the atv goes fine good drag and topspeed around 90km/h.
 

·
Registered
Joined
·
434 Posts
cant answer that one for sure, but sounds like you have some excessive belt slippage somewhere, how hot is the air coming out the vent when u rev it up? probably a good idea to take the cover off and inspect everything
 

·
Registered
Joined
·
6,824 Posts
What year did they redesign the cvt cover? They were nartow, soft and flimsy. May be worth researchi g.
 

·
Moderator
Joined
·
11,130 Posts
Sounds normal to me. They will flex and will also get hot when riding. So long as it don't leak and not excessively hot you're good to go.
 
1 - 9 of 9 Posts
Top