Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
2011 Sportsman 550 Touring 2 up
Polaris stock (came with the machine when I bought it) winch won't work.
I know it's getting correct voltage. Cracked it open and there is a good bit of water inside and rather rusty too. Have not opened the side that contains the winch motor itself but I'm thinking it's probably buggered.
Any suggestions for a replacement winch? Anyone know of water proof winches cause this one, it would seem, was not.

Cheers,
 

·
Registered
Joined
·
105 Posts
Check out KFI winches the stealth series they are not water proof but water resistint they come with. rope instead of cable check out there website they also make one hell of a winch bracket. Bearlake
 

·
Registered
Joined
·
2,412 Posts
clean it out and put it back together. The Polaris ones aside from the freewheel knob are fairly robust. I have taken mine apart to fix the know and was quite surprised.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #6
I think the motor is toast

Put power to the motor only and it doesn't make a sound or turn.
I'll have a go at that side tonight. The side with the gears and the freewheel selector just needs to be cleaned up and re-greased I guess. I don't know if the motor has brushes or what we'll see.
However, if this thing continues to let water in it will let me down out in the bush at some point I suspect
 

·
Registered
Joined
·
275 Posts
I'm very pleased with my Superwinch Terra series. I believe that it is supposed to be waterproof.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #8
Motor windings

are open...... feck!!

Anyhow, haven't spent much money on the bike for a while so this will be fun in a way.

Cheers,
 

·
Registered
Joined
·
171 Posts
Discussion Starter #9
Hold On A Second

So I took it all apart, cleaned it up, polished the brushes and the rotor contacts and viola! It works. Now the problem is it will only turn in one direction or the other. I know the switch is giving me +12 volts in one direction and - 12 volts in the other because I metered it. However when I hook up the motor it will spin in one direction but not in the other (unless I switch the connections at the motor).
So I know the motor is good and I know that the correct voltage is being sent to it but it doesn't seem to want to run in both directions.
Any suggestions?
 

·
Registered
Joined
·
2,412 Posts
that is how the winch works. The contactor sends + to terminal 1 and - to terminal 2 and the winch winds one way. The contactor reverses the polarity to wind the winch other way.

It sounds like your winch is working properly.
 

·
Registered
Joined
·
2,980 Posts
that is how the winch works. The contactor sends + to terminal 1 and - to terminal 2 and the winch winds one way. The contactor reverses the polarity to wind the winch other way.

It sounds like your winch is working properly.
But it sounds like the contactor is not
 

·
Registered
Joined
·
15 Posts
Guys & Gals . I really need some help, my polaris winch 2500 decided to snap its cable 4 times yesterday during snow , i will put in a syntethic rope , but how do you remove the puck that is holding the cable in
 
1 - 12 of 12 Posts
Top