Polaris ATV Forum banner

Polaris Xplorer 300 oil pump issue

451 Views 5 Replies 2 Participants Last post by  latebird
Hi all, just an old guy here that likes to work on anything with an engine. I tried to post this question once before, but I can't seem to locate it anywhere so I will try again. I recently received 2 Polaris Xplorer 300's with very low compression. One a 96 the other a 98. I tore the 98 apart and replaced the crank seals and did a top end. I also bench tested the oil pump and it worked fine. After reassembly I filled it with premix and it started and ran fine. After several runs I removed the oil line from the carb and noticed the oil pump wasn't working. Decided it would be premix only. I did the same procedure on the 96 but noticed the drive gear (worm gear) on the oil pump had close to 3/16 in and out play. I took the cover off and the pin that prevents the shaft from moving in and out was missing. Problem solved. Being old with little to do I pulled the motor back out of the 98. The pin was also missing on that pump. The drive I used on bench testing didn't allow the shaft to move, so I didn't see the problem then. Now both pumps work fine. I have no history with either machine other than they both had .02 over pistons in them when I tore them down. Can anyone explain how these pumps could have functioned as long as they did without the pin.
1 - 3 of 6 Posts
Thank you for replying. No picture of the pump I have seen, shows the pin. In the exploded view you sent, the pin would be under the bottom square cover. If you take the square cover off, you will see a small hole about .10 inches in diameter. The pin is in that hole. Hope this helps. I did take an old pump apart and it did have a pin in that hole.
I guess I have to accept that. It just seemed unusual for 2 machines from 2 different owners to have the same problem.
1 - 3 of 6 Posts