Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Does anyone know if there is a compresion release to use when trying to pull start....some times it nearly pulls my arm off when it jerks back.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
How do you activate it? By just pulling on the starter rope?..battery is not staying charged and I am having to pull start it sometimes one time it weill pull ok and the next it will nearly yank you arm off..
 

·
Registered
Joined
·
108 Posts
the compression release is built right into the cam shaft, when rotated it should let some of the pressure out, there is a chance that it's plugged, wore, or broke. I would check into the battery problem, and get that working. Then you dont have to worry about pull starting it so often. Replacing a cam can get spendy so do your homework. If you need a hand just let me know.
 

·
Registered
Joined
·
49 Posts
Pull starting a big single is an art. The trick is to get the motor turned to the right spot by pulling the rope slowly. Then giving it a good strong pull and follow through with the pull. Once you get the feel for it,it will be easy.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks to all...That would explain why sometimes it pulls with no problem...I suspect the magneto is not working or a lose wire...have to find them first. Imhuntingcrazy...can you give me an idea where to start looking as I can't seem to locate a manual for this ATV to download or purchase.
 
1 - 8 of 8 Posts
Top