Polaris ATV Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello, to start I love Polaris. I was wanting to know if anyone has heard anything about the 2011 sportsman 500 H.O.? There is a good deal on a brand new one and I couldn't decide, so far, on getting the 800 EFI or the standard 500? Anyone have any suggestions?

Do the belts slip bad on these machines? My friends suggest a Honda or Yamaha because of that issue, but I like the comfort and style of a Polaris. Just wanting to know if anyone had some wisdom on the issue.
 

·
Registered
Joined
·
1,491 Posts
I love mine. I did a lot of research on multiple brands and chose Polaris. And I am die hard BRP (Can-Am) fan. 500 has good power, rides nice, can push my 60" plow blade and they look mean. Aftermarket parts are everwhere.

If you have the coin, get the 800. The twin engines are smoother and faster. The 800 is EFI. I think my 500 tops out around 55, and I believe the 800s are 10mph faster. Someone can correct me if I'm wrong on the speed. I would have went for the 800, but I wanted to pay cash and to purchase some accessories immediately so it just wasn't in my budget.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Good Deal Man..."antoniodef"...Thanks. Yea the 800 about $2000 more I believe. Can't remember what it was at the dealership I went to. Yea my friend has a red 2010 500 H.O. He claims he got 65mph, who would believe him though?? What the hell, I'm in it for the trail riding anyway, If you smell what I'm stepping in.

I heard they had great power, I just wanted to hear it from some forum guys and previous owners. So hell yea...

If anyone knows anything about belt slippage on these Polaris's let me know...that seems to be a hot topic in my brain...
 

·
Registered
Joined
·
72 Posts
Good Deal Man..."antoniodef"...Thanks. Yea the 800 about $2000 more I believe. Can't remember what it was at the dealership I went to. Yea my friend has a red 2010 500 H.O. He claims he got 65mph, who would believe him though?? What the hell, I'm in it for the trail riding anyway, If you smell what I'm stepping in.

I heard they had great power, I just wanted to hear it from some forum guys and previous owners. So hell yea...

If anyone knows anything about belt slippage on these Polaris's let me know...that seems to be a hot topic in my brain...
I've got an 11 model and have had no issues with belt slip even with the 27 inch tires on it. I ride alot of step hills and it does fine, just put it in low range when going in deep mud holes or deep water just to prolong the life of the belt. All of my friends ride Hondas also and all of them gave me hell over buying a Polaris but after owning this machine for six weeks I've only had to be pulled out of the mud one time buy a Honda but have pulled out three of my friends Hondas eight seperate times and I go everywhere they do. Needless to say they don't give me such a hard time anymore.
 

·
Registered
Joined
·
24 Posts
170 miles on my 2011 500 h.o. deep mud, snow and water and not one slip. For the price i def recomend this bike.
 

·
Registered
Joined
·
109 Posts
have had a 800 for 2 and a half years with 27" tires on it from day one ,never had had belt slip once.if you dont get water in it you shouldnt have a problem.
 

·
Registered
Joined
·
9 Posts
So far my 2011 500HO has been great. It has plenty of power and has that great Polaris ride. Looked at a 400 but the dealer made me a deal on the 500HO. Glad I went with the 500.
 

·
Registered
Joined
·
58 Posts
Totally agree my 2011 500 HO has been awesome It is still very new but i have not had any belt slip and i flipped it the first day out and parts were easy to get and it was very easy to work on. recommend it highly.

I was trying to get a 2008 leftover Kawasaki Brute force 650 but I am very glad dealer was not cutting a deal on that cause it made be buy this one
 

·
Registered
Joined
·
2,496 Posts
the newer sportsmans seem to have there belts sealed well, you said ur buddy recomended yamahaha to get away from tht issue? i ride with new yammys and half of thier belts slip BAD.
 

·
Registered
Joined
·
1,420 Posts
I agree with "antoniodef",the 800 was not in my budget. I'v 85 hrs on mine, purchased in january- my first atv. No belt slipage! Good power. Love the way it rides. 26" tires on mine & tops out @ 57 mph. Ask dealer to throw in a free winch on the deal, mine did & it has come in handy!! Also make it a priority to install a-arm skid plates!!! Got a set on the way, unfortunatly did'nt see small hole in boot around cv & its trashed.(all it takes is a stick or small limb) In shop now for repairs, dealer trying to get it fixed under warranty. Not bikes fault- rider error. Service manual on way to. Found some on internet cheaper but after S&H about same price as dealer! Which ever you buy you wont be disapointed!!!
Hope this info helps.
 

·
Registered
Joined
·
2 Posts
I just a 500 HO and love it. I spent $6025 out the door which left me with money to get a plow and winch along with some brush guards.
 

·
Registered
Joined
·
63 Posts
i got mine this past weekend and love it. it is a very comfortable ride and has plenty of power. you definitely wont be disappointed! The only thing that im worried about or im just being too paranoid about it, but theres clicking/clanking noises when i slow down mainly when using the foot brake. ive heard it could be brake chatter? also heard their just noisy machines? and others say a cv boot...which i checked thuroughly yesterday. could it be defective?
 

·
Registered
Joined
·
6 Posts
I've done about 150km on my month old 2011 Sportsman 500. The bike is great and I look forward to each ride. The only issue I've had was a bad sensor that caused the hot warning light to remain on. $8200 with windshield, winch and hitch out the door. Gotta love Canadian prices. The dealers in my area will not budge on price.
 

·
Registered
Joined
·
226 Posts
i got mine this past weekend and love it. it is a very comfortable ride and has plenty of power. you definitely wont be disappointed! The only thing that im worried about or im just being too paranoid about it, but theres clicking/clanking noises when i slow down mainly when using the foot brake. ive heard it could be brake chatter? also heard their just noisy machines? and others say a cv boot...which i checked thuroughly yesterday. could it be defective?
I had the same noise with the foot brake. But when you use the hand brake it's fine. I know when you use the foot brake it's only applying the brakes to the rear right wheel. So you have all that weight on one side and one brake. Probably has something to do with that.
 

·
Registered
Joined
·
63 Posts
gammonjoshua, same exact thing. front brake = nothing..back brake = cringe b/c its a week old and im paranoid haha u said your "had" it...did it go away? still got it? what?
 

·
Registered
Joined
·
226 Posts
gammonjoshua, same exact thing. front brake = nothing..back brake = cringe b/c its a week old and im paranoid haha u said your "had" it...did it go away? still got it? what?
Still have the noise if I just use the foot brake. I have 2000KMs on the quad now.
 

·
Registered
Joined
·
4 Posts
Just brought my 2011 Sportsman 500 HO home this past weekend and love it! Installed 2500lb. pure polaris winch, front/rear brush guards and 26" rim and tires off a ranger...Rides great, cannot wait to get it on some trails soon!
 

·
Registered
Joined
·
63 Posts
awesome! yea im loving mine as well. dealer said the clanking sound was drivetrain noise..so i put it behind me and have been riding like i stole it! :racer: Cant wait to get some tires....and plenty more to come
 
1 - 20 of 22 Posts
Top