Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I just redone my 99 scram 500 4x4 with all new front end components. Bearings, seals, brakes, etc..
As all new parts went on, things just started getting tighter and tighter to spin the hub. I know that the seals and stuff are new are need some wear to move more freely..
When I got the hub on, the front wheels would spin with the rear wheels when I spun them by hand.
I then installed new brake pads and rotors and then it became harder to spin the front wheels by hand. And they don't spin with the rear wheels by hand.

Everything was installed to torque spec.

Is this ok, since everything is new and tight and needs some time break in time, specially the brakes and rotors.. they are tight?

I saw on a vid, where a guy replaced his armature plate and he stated the front should spin when you rotate the rear by hand.

is this the case or do you think I'm ok and its just tight components and needs some breakin time.
 

·
Registered
Joined
·
192 Posts
If the hubs nuts are tourqed to specs they should be fine. As far as the brake pads they will cause some drag till they seat into the rotor grooves. Take the machine out for a quick ride and pulse the hand brake multiple times which should seat the pads. If they are still hanging up drain and bleed
 

·
Registered
Joined
·
326 Posts
I would also check the allen adjuster screw on the brake caliper. Brakes will drag if the screw is not adjusted correctly.
 
1 - 3 of 3 Posts
Top