Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1 (Edited)
Hello,

yesterday i installed a power commander to my Scrambler 1000 XP 2016. It can be done, with little wiring. The standard throttle cable Scrambler has a TPS on left side of throttle bodies and you just need to unplug it and plug it in power commander. The e-throttle variant also has a standard TPS inside the casing.

You need to cut off TPS connector from power commander and wire the Black wire with white stripes to pink-violet wire (digital ground) and gray wire to dark green wire (TPS 1 SIGNAL OUT). You will need to extend the power commander wires for about 25 cm so you can route them nicely with original installation

I post this if in future someone will need this info. The throttle body is same on some RZR-s. Managed to figure this one out with Dynojet team.

You can easily disasemble connector and push new wire next to old wire under rubber water plug and solder it to connector. So you will keep your waterproof connections. ( i forgot to take a picture of it, but will if someone might need it). Dont forget to calibrate TPS in power commander with engine running and warmed to operating temperature, otherwise you will have about 5 % difference.
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter #2
Ok, just a little update.

DO NOT INSTALL POWER COMMANDER TO E-THROTTLE VARIANT

The reason is that the power commander injects some noise, signal or whatever that makes your ECU to hold the throttle after releasing it. I almost crashed after my throttle got "stuck" few times. After releasing the throttle it will fall to about 3000-3500 RPM and stay there until you brake and then the engine will loose RPM. It is was amazingly dangerous but managed to get out of it in 1 piece.

I have deinstalled it yesterday and no problems anymore, bike Works perfect. I will rather run a little lean than kill myself.

The Dynojet will afcourse not accept the return of power commander, terrible company. They even stopped responding to my e-mails after i told them what happened.
 

·
Registered
Joined
·
1,512 Posts
Any chance something was installed improperly?
I mean it seems simple enough but thought I'd ask for the good of the group. Thanks for the update btw.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
Any chance something was installed improperly?
I mean it seems simple enough but thought I'd ask for the good of the group. Thanks for the update btw.
All was installed and double checked per their instructions. Nothing to go wrong actually, plug 2 injectors and solder 2 wires. Im Electronic person, so im sure i wired it wrong. But this power commander is designed for old variant with throttle cable and stand-alone TPS. But new e-throttle version is not compatible, altrough i was convinced by Dynoyet i will not have any problems before installation (they never tested it and changed mind after installation)
 
1 - 5 of 5 Posts
Top