Polaris ATV Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
After a ride in the mud the other day I stopped by a lake where I proceeded to clean off my machine. Drove in to about a foot of water (below the footwells) and splashed water on the machine to clean off the access mud.

Drove back home and the machine wouldn't turn off with the key. Tried the kill switch and it shut off. Figured it was likely water somewhere that it shouldn't be and figured it may dry out and be okay.

Next time I tried to start it, the machine started okay, but wouldn't turn off with the key or the kill switch. I am pretty sure the key (ignition switch) and the kill switch are functioning okay...as I rode for a bit and hadn't notice that the key was in the off position and after a few minutes started to get a low voltage on the display. Swapped the key to the on position and it imediately went away. Tried the same thing with the kill switch and same results. So it appears that the two switches are working okay as when they are in the off postion the system isn't charging the battery, and then when turned back on all alerts went away.
In order to actually turn the machine off, I pulled the relay to the EFI as I know that will stop the motor. Now I have a second problem as it won't start as the computer has a check engine sign showing up.

So, anyone know how to clear the false check engine alert? Also, anyone know if they ignition circuit is by default closed or open? Would I be correct in assumign that it is likley a ground issue? Unfortunately electrical problems are not my specialty.

Thanks for any help.
 
1 - 1 of 1 Posts
Top