Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i just got 06 predator 500. It was runnin way rich and had alot of oil in the airbox. replaced the main jet in the carb which the guy had a 180 in it and i went back down to 152.5. that helped a good bit with it running rich and helped with it missing at half throttle. with this done it was running alot better with about 3/4 throttle until it missed. noticing the air filter had alot of oil on it, took it out and it runs just fine. A tad bit rich but i think its ok. if u have any comments on this please do help. Now the oil issue i cannot figure out. Change the oil and oil filter. put about 2 and 1/4- 2 and 1/2 qts oil. still doin it. can literally see it comin out of crankcase res hose into airbox. maybe still a lil much oil idk. I opened up the check valve or anti-drainback valve to see if the ball bearing was in it and it wasn't. so i got another and put that in. some ppl say its better without. not sure if i agree. anyway, im still having a big issue with the oil pourin into airbox. i jus dont understand. it runs fine and starts right up. I rode it for 5 mins and filled 1/2-3/4 of a 20oz bottle with oil comin outta crankcase vent hose. ive tried everthing i can think. oil pump seems fine, no blockages, filter is fine. idk please help
 

·
Registered
Joined
·
119 Posts
i just got 06 predator 500. It was runnin way rich and had alot of oil in the airbox. replaced the main jet in the carb which the guy had a 180 in it and i went back down to 152.5. that helped a good bit with it running rich and helped with it missing at half throttle. with this done it was running alot better with about 3/4 throttle until it missed. noticing the air filter had alot of oil on it, took it out and it runs just fine. A tad bit rich but i think its ok. if u have any comments on this please do help. Now the oil issue i cannot figure out. Change the oil and oil filter. put about 2 and 1/4- 2 and 1/2 qts oil. still doin it. can literally see it comin out of crankcase res hose into airbox. maybe still a lil much oil idk. I opened up the check valve or anti-drainback valve to see if the ball bearing was in it and it wasn't. so i got another and put that in. some ppl say its better without. not sure if i agree. anyway, im still having a big issue with the oil pourin into airbox. i jus dont understand. it runs fine and starts right up. I rode it for 5 mins and filled 1/2-3/4 of a 20oz bottle with oil comin outta crankcase vent hose. ive tried everthing i can think. oil pump seems fine, no blockages, filter is fine. idk please help
Try a new hose
 

·
Registered
Joined
·
80 Posts
Your oil ring has nothing to do with power. If you had a bad compression ring that would affect how the machine runs. I'd bet anything that's your problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
aight. well in oreder to do it right i should prob get all new gaskets, right? and if this is the prob, u think more than just the ring is gonna be messed up?
 

·
Registered
Joined
·
80 Posts
It will need to be torn down and everything measured and checked for proper clearance. If it ingested dirt at one time or another that could be what wrecked your oil ring and that could do damage to the bore, piston and compression rings as well. No way to know till you get in there. You could pull a compression test, however just because it passes a compression test doesn't mean there is no damage. If you have no engine work experience you may want to consider taking it to someone who does. The Predator engines aren't the simplest to work on. You should at least get a service manual if you do it yourself!
 
1 - 7 of 7 Posts
Top