Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
So I riding today with my dad and decided to go balls deep into a really slushy waterhole, of course I got stuck and i was in the process of winching myself out when the engine hot light blinked a few times then the bike shut off all together, not like sputtered like a mechanical failure but just shut off like I had just turned the key off. Reading through the service manual it looks like the coolant temp controller/circuit breaker and the BAT_PROT breaker are controlled by the ECM or sure power box. IM thinking that It got hot and the breaker tripped which shut it off and now it wont "automatically reset"

HOWEVER! i think i may be in luck because its one of the black made in china boxes that i believe were under recall... So I wonder if they will still honer the recall, if it is truly the one. I'll call tomorrow and find out.
PS when I ran my vin with the Polaris website this is what showed.

Bulletin Status Bulletin Information
Bulletin Completed ATV-05-01L-LABOR ASSISTANCE / ATV-05-01T
Superceded by bulletin ATV-05-01T ATV-05-01R - REVISED ECM REPLACEMENT
Bulletin Completed ATV-05-01T - REVISED ECM REPLACEMENT / TEST
Bulletin needs to be applied ATV-08-01B - ECM REPLACEMENT

Does that means its under recall?
 

·
Registered
Joined
·
200 Posts
Discussion Starter #3
I wouldn't tell them I was stuck or anything I'd hust say it quit whole riding.

My S3 addiction!!
I'm hoping that they will just give me the new one considering I already have the old one out to test continuity on the pins and the four wheeler is completely taken apart...
 

·
Registered
Joined
·
200 Posts
Discussion Starter #4
Wahoo! my local dealership replaced it under the recall today, all is solved and the beast runs again!
 

·
Premium Member
Joined
·
11,409 Posts

·
Registered
Joined
·
7,464 Posts
Cool beans..... glad to hear it was that easy!!

I'm pretty sure ours has been done, as it has a couple "campain #" stickers under the seat on either the frame or airbox lid.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #8
The old one was black with heat sink fins on it and the connecters plugged directly into it. The revised new on has a connector harness that plugs into the OEM harness and is silver with heatsink fins on it.

Sent from my HTC6435LVW using Tapatalk
 
1 - 8 of 8 Posts
Top