Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
2016 Sportsman 110 EFI Youth.
This has only been ridden four times. It has 5-8 hours on it. We tried to start it this morning. It made a strange noise. Now the starter is just free spinning. The dealer is a good distance away so I'm hoping I can fix this here. Is there a troubleshooting procedure or common problem with these that I may be able to fix on site? It snowed here. He tried to ride it in the snow yesterday but it just kept bogging down in 7" of snow. This morning is when the trouble started when we tried to start it.

The boy is out of school tomorrow and has some free riding time since he couldn't ride it today. I'm hoping this is something simple to fix.

Thanks for any tips/assistance/guidance.

Paul
 

·
Registered
Joined
·
11 Posts
good luck with finding anything on these bikes.Santa droped off 2 of them for my kids last year and ive yet to find anything on them yet.Mabey now that the bikes have been out for a year you will have better luck than i did.I also see you are in eastern NC to.Im not far from raleigh.How about you? Mabey we could get together and ride sometime.I have twins,a boy and a girl 10yrs old.As i said they both have a sportsman 110,I have a sportsman 570 that is down right now,but have a honda i am ridding right now.Hit me up if you like.You might can find some old post from me as i had to change my user name because i lost password.Old account was Brucewayne
Im not so good with mechanics but it sounds like the bendix in the starter to me.id try tapping on the starter .Again im no mechanic
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
So, the starter eats gears. I'm on my third set. Others report similar occurrences at even much higher rates.
 
1 - 4 of 4 Posts
Top