Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have an 08 sportsman 500 carb. I have no electrical power anywhere. turn the key and nothing. the battery is fine. is there a main power fuse somewhere? where do I start?
thanks
Cory
 

·
Registered
Joined
·
424 Posts
Yes there is a main fuse under the front cover below the headlight pod, also try your kill switch move it both ways and back to on position.
 

·
Registered
Joined
·
424 Posts
Try this stuff first then we can move on to other tests and checks to see what's up hopefully something simple. Let us know.
 

·
Registered
Joined
·
286 Posts
I have an 08 sportsman 500 carb. I have no electrical power anywhere. turn the key and nothing. the battery is fine. is there a main power fuse somewhere? where do I start?
thanks
Cory
http://parts.polarisind.com/Browse/Browse.asp


Another member sent me this link when I was having issues locating a fuse. Just enter atv, your year , and model and you will have a complete parts diagram
 

·
Registered
Joined
·
60 Posts
I had a similar issue before. Put the key in, turn it and no dash lights or anything. Turned out in my pod, the wiring harness from the key down, one wire had worn right through and two more were on their way. Could have been because of my broken bottom pod there was just enough room for the wires to move, or too tight lock to lock or something, hell if i know. Soldered wire back together, put on heat shrink and so far so good.
 
1 - 5 of 5 Posts
Top