Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a Sportsman 500. It began stalling, but quickly started up again. It then began stalling and it backfired a couple of times. I added some dry gas, started it up and let it run for 10 to 15 minutes, occasionally running up the rpms to insure that it continued running. Everything was fine until I put it in gear. As soon as I put it in gear, the check engine symbol came on and it stalled. It did this several times until I gave up.

Vito
 

·
Premium Member
Joined
·
20,001 Posts
First off, welcome to the board!
 

·
Registered
Joined
·
1 Posts
500 HO Stalling

I have a 2010 Sportsman 500. I was riding it and the fuel gauge said I had a half tank but when i stopped for a break i could not start it again. The fuel was almost empty so i added fuel. Now the thing will not start unless i give it some throttle. Once i go to idle it just stalls out. Any ideas what went wrong? I am not a mechanic so not sure what i should be looking at.
 

·
Registered
Joined
·
10 Posts
I have a 2010 Sportsman 500. I was riding it and the fuel gauge said I had a half tank but when i stopped for a break i could not start it again. The fuel was almost empty so i added fuel. Now the thing will not start unless i give it some throttle. Once i go to idle it just stalls out. Any ideas what went wrong? I am not a mechanic so not sure what i should be looking at.
I have a 2002 sportsman that had the same problem. I had too much slack in the throttle linkage and the etc switch or whatever it is called would kill it at idle. I am not sure if the 2010's are the same, but you might check the slack in your throttle cable. IIRC the service manual said you should only have like 1/8" or so of slack.
 
1 - 4 of 4 Posts
Top