Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
Looking for some help on my 2014 Sportsman 800. When I shift into gear sometimes it doesn't go in then when I give it gas it catches all the sudden and goes into gear. Also sometime when I put it into gear and dont hear it click in Ill rock the quad forward with my weight and it will click in. Can anyone give some insight on maybe whats going on and where to look for the issue, thanks.
 

·
Premium Member
Joined
·
9,943 Posts
What's the idle rpm when it doesn't want to go into gear. Idle rpm ahold be 1250+/-100, IIRC.
 

·
Registered
Joined
·
120 Posts
Discussion Starter #3
Thats about what it idles at. It feels like something sticking almost.
 

·
Premium Member
Joined
·
9,943 Posts
Pull the clutch cover. Primary sounds like it's not open all the way.
 

·
Registered
Joined
·
120 Posts
Discussion Starter #5
It does when its not running to. If I put it in gear and push it forward it clicks in.
 

·
Premium Member
Joined
·
9,943 Posts
Post up a video.
 

·
Premium Member
Joined
·
9,943 Posts
Is the bell crank stripped??
 

·
Registered
Joined
·
120 Posts
Discussion Starter #11
I thought about replacing the bell crank anyways and seeing if it changes it at all. Is there any better aftermarket ones?
 

·
Premium Member
Joined
·
9,943 Posts
Not to my knowledge. You should be able to tell if it's slipping or not just be watching the linkage and bell crank as the machine is being shifted.
 
1 - 12 of 12 Posts
Top