Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
So I just purchased a 2007 Phoenix for $1,000 for my wife.

At first, I couldn't get it to turn over without crossing the terminals on the solenoid. I downloaded shop manual for $5. I looked at the diagram, and everything seemed alright. I then did a search, and found out I had to hold the brake lever. Odd, but at least that was solved. It worked a few times, but then only clicked. So I charged the battery. Still only clicked. Bench tested the starter. Starter is fine. Cleaned all connections. Still only clicks. Replaced the battery. Still clicks. Tried putting the starter directly on the battery. Nothing.

I'm stumped. Any ideas?
 

·
Registered
Joined
·
10 Posts
Please don't be offended. .. but were you in nuetral when trying to start it? Mine is a 13... but in nuetral it starts...in gear I have to hold the brake lever. Maybe that switch is funky?

Sent from my SCH-R970 using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
The neutral light is on, and the shifter is in the middle click.

What has me stumped is how a battery charger putting out like 20 amps tops is turning the starter just fine on the bench, but when I try placing the starter on top of the battery, bypassing everything, it does nothing. There's almost no voltage drop or anything.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
I ordered a new starter. Should be here Tuesday.

In the mean time, I got it to start pretty easily with the kick starter. It's pretty fun for a 200cc.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Well, starter arrived today. Apparently that was the problem, because it starts easily now.
 
1 - 5 of 5 Posts
Top