Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
can some one please tell me were i can locate the starter on my 03 250 trailblazer is,put in a new battery and still all it does is click when i try to start it ,could this be a starter gone bad , how would i test it
 

·
Registered
Joined
·
483 Posts
The starter will be on the bottom of the engine, it may have a skid plate you will have to take off to get access. First be sure all connections at battery are good then the connections at solenoid then the cable that connects to the starter. A loose or corroded connection could be the problem. If all is good then try crossing the two posts at the solenoid together, this will check for a bad solenoid. If still nothing then most likely the starter. One last thing to try, have a buddy or someone help you with this; as you are pushing the start button have someone tap at the end of the starter with wrench or something metal. If the brushes in the starter are getting bad this could help them make connection inside. If this works, still plan on replacing the starter.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
starter

i have not changed the starter yet,but i did put in a new battery,still nothing,started it with the pull cord,ran for about 1 hour like that,shut it down for lunch,than tured the key for power to pull start it and the battery was dead,some one said i might have a dead short in the starter???.so i remover the power cable from the starter ,tapped it all up[so not to short out],re-charged the battery.SHOULD I BE GOOD TO RUN JUST BY STARTING IT BY THE PULL CORD???? THIS SHOULD NOT KILL THE BATTERY~~~~~ RIGHT,i this is worng please
 

·
Registered
Joined
·
6,903 Posts
if you pull start it, the battery still should be getting juice from the stator. sounds like you have an electircal issue and something is draining the battery.
 
1 - 6 of 6 Posts
Top