Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2012 Polaris 500 sat for 4 years. Replaced starter solenoid 2 days ago, all the fluids. Won't idle unless chock is half or more pulled out. Took it down the road and ran great till I slowed down to turn then shut off and not enough battery to restart. Is this a battery problem or something deeper?? Anyone, anyone, Bueller, Bueller?? Thanks in advance!!
 

·
Registered
Joined
·
978 Posts
Put a meter on the battery and make sure it is charging.

As for it shutting down on you...
Will it idle with the throttle just lightly pressed? Check cable adjustment.
Increase idle with idle screw.
Otherwise go through the following; airfilter, airbox, airbox to carb tube and the carb boot (all clean and no pinholes or leaks). Can test boots with carb cleaner for change in rpm. If all those appear in good condition the idle fuel circuit may be clogged and need a thorough carb cleaning.
 

·
Registered
Joined
·
7,965 Posts
It needs at least 9 volts in the battery to fire the ignition - put the battery on a tender (.75 -1.25 amp automatic charger) until fully charged then check the charging system.

If it won't run without 1/2 choke, the carb needs serviced - hopefully you drained the fuel tank and put in some non-ethanol 87-91 octane gas?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yeah I drained the tank and I've never run it with ethanol gas. Airbox and filters are all clean. Looks like I'm gonna have to tear it down to the carb. Thanks guys
 
1 - 5 of 5 Posts
Top