Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I have a 2005 tld pred 500. Everything on it has been perfect, but when i tried starting it today something was wrong with it. I pressed the start button and the starting didn't even crank, just sort of whined. I released the button, then pressed it again. then it grinned a bit, cranked and started right away. It did this awhile ago, but it just stopped, except when it did it before it would catch. Does anyone know what's wrong. It usually starts first push everytime
 

·
Registered
Joined
·
3 Posts
I have a 2005 tld pred 500. Everything on it has been perfect, but when i tried starting it today something was wrong with it. I pressed the start button and the starting didn't even crank, just sort of whined. I released the button, then pressed it again. then it grinned a bit, cranked and started right away. It did this awhile ago, but it just stopped, except when it did it before it would catch. Does anyone know what's wrong. It usually starts first push everytime
Hey this same thing happened to me when i first got my scrambler 500 ended up being the 2 little connectors on the left side that go into the kill switch . Im not sure if you had power to the display. but i had no power to tell me i was in neutral or revers, the starter would not crank. I did have power to the lights but that was it. check this video out . and at the end he shows you the 2 cables or clips that im talking about. Hope this helps. If it does help you should thank the guy in the video on youtube :) saved me from going bald. but if its making a wine sound when you hit the start button. sounds like to me your starter is froze up from ejecting the gear from engaging into your flywheel. Could be gumed up with stuff. I know that when a starter goes out in a atv or car for that matter. there is no warning .
 

·
Registered
Joined
·
521 Posts
check the slack in the throttle cable first then my guess would be new battery, predators are ruff on batteries i had too change mine three times when i owned it
 
1 - 3 of 3 Posts
Top