Polaris ATV Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi everyone I have a 2012 polaris rzr 900 xp. have a question on stator and vr. Stator wires getting very hot 250 degrees plus within about 12 to 15 minutes of idling. Old stator went out and replaced it with new stator and vr. Wires got so hot it melted the connector cut old connectors off of old vr and stator and spliced together with heat shrink connectors and good krimp still doing same thing. I do have a lot of accessories but also have 2nd battery and battery isolator so all accessories are on second battery. only thing that is on main battery is machine and winch. Have tried disconnecting battery isolator and winch. No help. Does anyone have any ideals?
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
12,881 Posts
With two batteries your stator is trying to overcharge on amperage and that's why your wires are getting hot
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
12,881 Posts
You're asking the charging system on your ATV to do something it was never designed or intended to do
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
I have two light bars front and rear. Stereo system whip lights under glows . All of which are connected to aux battery. Which is completely disconnected from the main battery. Only thing hooked up to main battery is the machine itself and winch.
 

·
Administrator
Joined
·
18,198 Posts
First guess is a damaged rec/reg, faulty battery or a rec/reg connector that is not rated for the current draw. If it is the stator wires that are getting hot and the rec/reg is known to be good, then the stator may have shorted windings.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
First guess is a damaged rec/reg, faulty battery or a rec/reg connector that is not rated for the current draw. If it is the stator wires that are getting hot and the rec/reg is known to be good, then the stator may have shorted windings.
Checked stator reference to ground on all three wires. All good. Checked ac current from stator all three is about 20 to 21 ac volts while idling. checked vr diodes not quite .51 volts per wire only one was other two were .495 and .48 something. Have we vr coming in today and will try that.
 
1 - 11 of 11 Posts
Top