Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Long story short I'm attempting to fix my father in laws 4 wheeler. It was shut off before it died. All you could see in the water was the seat and handle bars. Now I pulled the battery and hooked a battery charger directly up to the terminals of the 4 wheeler without a battery. the display doesnt turn on, nothing powers up. The key does not make the starter function. I then connected the positive wire to the junction box on the left side by the battery and the starter turned over. Is there a fuse somewhere that I'm not seeing? HELP!!!
 

·
Registered
Joined
·
6,903 Posts
sounds like the starter solenoid is shot

either that or your key switch is shot, and its not sending the signal to the solenoid to turn over
 

·
Registered
Joined
·
877 Posts
then it could be the key switch like blue said
 

·
Registered
Joined
·
6,903 Posts
i would pull the key switch out, figure out which wires is you main power, and which wire the key switch makes hot when you turn it to the "on" position and see if everything comes back
 

·
Registered
Joined
·
2,352 Posts
you might be better off using a set of jumper cables and a known good battery, hook those up to the terminals and see what it does. battry chargers depending on what type you are using ,have spikes of current under certain conditions and might burn something up ,like your control module.
Clean all your connections,look at the kill switch
 
1 - 7 of 7 Posts
Top