Polaris ATV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I fell off in a hole and went over the front rack. Air box was filled and combustion chambers were filled. I blew them out, WD40'd them and vacuumed them out. Oil looks to not have water but am going to drain, refill and repeat a few times. I tried to turn over and it sounded like something happened but then it went to the click, click like battery is dead or the system does not like something? Any one have any ideas? Thanks.
 

·
Registered
Joined
·
322 Posts
You didn't say but if you haven't drained the exhuast system you need to. There big heavy machines but you have to tip them on there rear to drain the water out of the pipe and muffler.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
I have not tipped it yet. I need some help so will prolly try tomorrow when friend comes over. I am going to try and get a charger just in case the battery is just weak (and thus the clicking).
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:fest30:
 

·
Registered
Joined
·
13 Posts
I did the same thing. Yes check exhaust, you can pull it apart at the spring connection to drain it. Remove plugs and turn over engine with plugs out to blow out the water there. I had to drain the belt box and the tranny oil and the front diff fluid. I now think I should have drained the ADC fluid (if you have that) and I have not located the drain and fill plugs for the rear drive as I have an 800 X2 and it is different from the regular sportsman.
 

·
Registered
Joined
·
174 Posts
remove the spark plugs and crank the motor over, if it dont crank only clicks you shorted something electrical out. ive swamped mine upside down in 7 feet of water a few times and all i had to do is pull the plugs and change all the fluids and she was 100%. no need to tip the machine.
 

·
Registered
Joined
·
174 Posts
they are sealed splashing through the mud and water yes. but they have vents. water runs down the vent tubes and ya..... also if you read in your owners manual it says not to go through water deeper then basically half way up your rim... dumb I know. but those seals are ment to keep oil in not water out.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
Thanks. Almost made the mistake. Anyone know what Mobil One to use with the ADC? I think the gear is 75/90. Also how hard is it to take off the cover the the transmission? I had like 2 gallons on there and need to clean it out. Is there a gasket or sealant holding it on?
 
1 - 9 of 9 Posts
Top