Polaris ATV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
96 Trail Boss 250. No issues starting, 99% of the time runs great on flats, would occasionally have an issue with a hill, run it on a flat for a few then climbs the hill fine, usually. After a few months of that, I swapped the carb boot, new air filter, cleaned the carb (wasn't clogged/dirty, just did it for good measure. After the new parts, same issue.

I'm thinking time for a top end, but it mostly runs great and has no starting issues. But could it be something else, like a coil pack dieing giving weak spark from time to time? Any thoughts?

Sent from my E6910 using Tapatalk
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
7,536 Posts
Your question has now been logged into the queue and the next available forum member will answer you shortly. You will be given more advice than you could hope for.
 

·
Registered
Joined
·
13,430 Posts
When was the last time the rings were replaced? I always replace mine every couple of years in the two strokes I had. I don't have any 2 strokes any more, but my race bike routinely gets a new piston and rings every 30 hours (about twice a year)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
I've had it for 4 years now and I've never changed them. Have no clue how long before me it was ever done. But this is where my mind went, time for a bore and hone, just because I don't know the complete history on it.

I've got another that I picked up 5 years ago that needed a bore and hone when I purchased it. Still runs strong today, put at least 100 hours a year on it.

Sent from my E6910 using Tapatalk
 
1 - 4 of 4 Posts
Top