Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just wondering if any one else experienced the temp light blinking and then going into safe mode. First time out riding and this happened! At dealer now and they said it is the thermeister which connects at bottom of radiator which controls temperature and is tied in with fan?? Not sure of the term thermeister?? Any input would be appreciated cause I hope this issue will be solved.
 

·
Registered
Joined
·
325 Posts
Definitely a bad part somewhere. Is the fan running?

I had mine out last weekend, did 70 miles in 103 degree heat, the fan ran most of the way; no overheating problem at all.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:Med:
 

·
Registered
Joined
·
173 Posts
Just wondering if any one else experienced the temp light blinking and then going into safe mode. First time out riding and this happened! At dealer now and they said it is the thermeister which connects at bottom of radiator which controls temperature and is tied in with fan?? Not sure of the term thermeister?? Any input would be appreciated cause I hope this issue will be solved.
I have an '13 850XP Touring that is doing the exact same thing. It is in for the third time right now. They haven't changed anything at the rad yet as you described but maybe I should point it out to them.

So they changed fan relay, thermal overload switch at the engine and adjusted the ETC switch. Now they are looking at the wiring and possibly the ECU. If your problem is cured when you get it back please let me know and I will do the same. My dealer claims they haven't seen this issue.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Mine is there now and Polaris approved them to replace the thermester which they said is causing the issue.They have to remove head gasket cover to get to whatever this part is. Exhaust gaskets also have to be replaced too. Really bummed cause the machine only has 5 hours on it! Coolant has to be replaced, So I asked them to replace it with engine ice. My dealership is really cool and they said it wouldn't be a problem and also assured me it would be like factory new!:)
 

·
Registered
Joined
·
173 Posts
Just got mine back from dealer. The mechanic was actually able to get the problem to come on this time. He is convinced it was the thermostat sticking intermittently. He replaced it and I guess we shall see when i take it out. says he also greased every connection he touched while going through the wiring.

Good luck with your unit I will let you know if this fixed mine.
 
1 - 6 of 6 Posts
Top