Polaris ATV Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 2013 Polaris 850, the check engine light will flash on when I let off the throttle, if hit the throttle normal is will go out, if I move it slowly the light will stay on and the engine goes in limp mode. I checked the engine code, it is #7, stuck open throttle. Does anyone have any ideas? possible tps sensor?
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
68 Posts
hey Peter just take her in and trade for the Scrambler 1000 you know you want it haha...
 

·
Registered
Joined
·
3,230 Posts
I just had this and the zip tie on my rs ha dle ar was too tight and caused it.
 

·
Registered
Joined
·
222 Posts
if you are very sure everything is fine and you never use the ADC, and can deal with a stuck throttle with no limp mode... you can just remove the cover of the throttle lever and stick someting between ton contacts of the throttle stuck switch or cut on of the wire. on my scrambler 850 I did that(stick something between the contacts of the switch) now no more problem with that
 

·
Registered
Joined
·
11 Posts
Mine starting doing this when I brought it in for the 50 hr service, the service guy noticed it as he was bringing my bike around to my truck. All they did was pull the cover off the throttle and worked it while spraying some WD-40 and they adjusted something with an allen wrench or something. I haven't experienced the problem since.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
which wire

if you are very sure everything is fine and you never use the ADC, and can deal with a stuck throttle with no limp mode... you can just remove the cover of the throttle lever and stick someting between ton contacts of the throttle stuck switch or cut on of the wire. on my scrambler 850 I did that(stick something between the contacts of the switch) now no more problem with that
what wire do u remove and does the check light s
stay on?
 

·
Registered
Joined
·
222 Posts
if you are very sure everything is fine and you never use the ADC, and can deal with a stuck throttle with no limp mode... you can just remove the cover of the throttle lever and stick someting between ton contacts of the throttle stuck switch or cut on of the wire. on my scrambler 850 I did that(stick something between the contacts of the switch) now no more problem with that
what wire do u remove and does the check light s
stay on?
The simple way is to open the throttle lever cover and you will see a contact between two wires, just put a piece of plastic(I used a piece of zip tie) in the contact to keep it open, no check engine will stay on or anything, but if you have adc it will nt work anymore. My scrambler 850 is running like that perfectly since about 3000km
 

·
Registered
Joined
·
4,629 Posts
Have you tried adjusting the ETC?
 

·
Registered
Joined
·
434 Posts
adjust your throttle cable about half way down handlebar so u have 1/8th inch of freeplay that should solve your problem and thats how you adjust the ETC
 

·
Registered
Joined
·
34 Posts
yes try setting the freeplay you should have 2 mm of freeplay and how does your dalton springs work
 

·
Registered
Joined
·
4,629 Posts
How do you adjust etc?

Sent from my SCH-R970 using Tapatalk
About 3" from the the throttle box is a rubber boot covering the adjustment knob. Peel back the boot, loosen the lock screw, and turn the adjuster.

If you remove the throttle box cover, you may see the 2 metal contacts touching and as you add tension to the adjuster they will spread apart. Once done, don't forget to tighten the lock screw. Tried to post pics but tapa talk being annoying about it, sorry.




Rather be riding, instead I'm using Tapatalk
 

·
Registered
Joined
·
1,159 Posts
Ok I removed the 4 screws in the throttle cover and I had 1/4" if not more end play on throttle cable. So I tightened cable up to get rid of slack and left 2 mm. Will see how this works.

Sent from my SCH-R970 using Tapatalk
 

·
Registered
Joined
·
4,629 Posts
Ok I removed the 4 screws in the throttle cover and I had 1/4" if not more end play on throttle cable. So I tightened cable up to get rid of slack and left 2 mm. Will see how this works.

Sent from my SCH-R970 using Tapatalk
Hopefully it will work. As they break in, the cable loosens up and the ETC senses a stuck throttle.


Rather be riding, instead I'm using Tapatalk
 

·
Registered
Joined
·
90 Posts
Dont be discouraged if it doesnt work. I have been fighting it on my 2013 since new and 2300 miles ago. I just defeated it like the above posts outlined and moved on. Good luck.
 

·
Registered
Joined
·
1,159 Posts
Well I ended up going through the cable adjustment one more time and enabled to etc contacts and no check engine light. I must not of adjusted the cable tension right the first time I tried it.

Sent from my SCH-R970 using Tapatalk
 
1 - 19 of 19 Posts
Top