Polaris ATV Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Has everyone noticed slight play in there tie rods? I just clicked 240 miles on my rig and noticed a little play in them this morning when I was washing it.
 

·
Premium Member
Joined
·
140 Posts
I have replaced my tie rods twice. First set at around 1500 and the second set at 4000.
 

·
Premium Member
Joined
·
9,467 Posts
A little play is nothing to be concerned with. How much is a little?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #5
Hard to say for certain, I didn't have a helper to do the bars while checked it out fully. It's not a lot by any means just a surprising that there is any ionly went for few rides.
 

·
Registered
Joined
·
55 Posts
I am putting the All Balls Upgraded Tie rods and ends on my 2016 Sportsman 1000 Touring. At less than 800 miles I am getting some play on the ends.

I could not find anyone that makes a tie rod end that can be greased. The quality on the All Balls parts looks good they are considerably stronger than stock.
 

·
Registered
Joined
·
1,144 Posts
i find most times the play is in the steering splines and not the tie-rods, specially with your low mileage ,
i've got zero play in my tie-rods at 2500 miles, but the play in the splines is CRAZY ,
There is a good thread in " steering play fix " or something if you feel the play in the steering.
 

·
Registered
Joined
·
55 Posts
i find most times the play is in the steering splines and not the tie-rods, specially with your low mileage
On my machine we removed the tie rod to fully inspect the parts, the outer end is loose. That's when we made the decision to upgrade to the Heaver All Balls parts.

It is frustrating my buddy can get tie rod ends and ball joints for his RZR that can be maintained with grease but I cant for my Sportsman.
 

·
Premium Member
Joined
·
9,467 Posts
You TRE doesn't need grease zerks to be greased. Just a needle fitting on your grease gun slipped up under the rubber boots does it.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #11
I definitely agree it is the spline, I noticed the play on the inner tie rod witch is unusual to wear before the outers. I read the steering play thread and I'll try the lock tight trick
 

·
Premium Member
Joined
·
140 Posts
Rutcutter did you replace yours with after market tie rod ends?
I bought American Star Racing. First set was their least expensive ones at around $89. Second set was their racing rods that sell for around $170. They did work with me and discount the second set by half. Great customer service. They have a web site and also sell on Ebay.
 

·
Premium Member
Joined
·
140 Posts
When my OEM set went bad it was within the warranty period but the dealer claimed it was normal wear and tear and was not covered. Same thing with my fuel pump, it started crapping out during the warranty period also. They wouldn't fix it either. Probably a good thing because they would have put a junk Polaris one back in. I stuck an aftermarket pump in and haven't had any issues after thousands of miles. RANT OVER:grin
 

·
Registered
Joined
·
140 Posts
Yes I have a 2018Sportsman 1000XP seen the tie rod loose for day one. I thinking about trying to put grease in them with a grease needle.
 
1 - 16 of 16 Posts
Top