Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
I bought a set of interco swamp light tires a few weeks ago. I've taken them to 5 different dealers not a single one of them can get the tires to bead up. When I got them I un packed them and left them in the house also stuck 2x4's between the lips to open them up from shipping. I even took them to a company that mounts semi and tractor tires. The rims are stock 14" Polaris rims and the stock tires are a size smaller then the ones I ordered?! Idk what else to do.:aargh4::pedro:
 

·
Registered
Joined
·
806 Posts
From what you posted I'm guessing the tires will inflate but the beads won't seat on the wheel? In that case I use liquid hand soap on the tire and even a little on the wheel and inflate it to 30-40 psi. Or you can't get the tire to contact the wheel enough to inflate at all? In that case I've used a ratchet strap around the circumference of the tire to squeeze it enough to make contact and inflate it, using the same hand soap lube.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #3
Bead won't seal even with a 100# cheater tank, we've tried all those methods thanks
 

·
Registered
Joined
·
450 Posts
After all that trouble, I'd contact the vendor you bought the tires from. Sounds like a defective set if 5 different shops can't get them to mount.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #6
This is what the dealer told me to do, and yes we tried all the conversation methods.

Guy told me to get some heat in them then put some 2x's on the side wall of the tire then hit it with the cheater tank while pushing down on the rim.

My buddy who's mounted 1000's of tires took them to another tire shop I'm unsure how they went about getting them on.

Thanks guys
 
1 - 6 of 6 Posts
Top