Polaris ATV Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hey guys, new here. Just picked up a 2015 sportsman 850xp for a steal because of this weird issue it has.
The quad acts like you have no battery hooked up at all until you disconnect the voltage regulator, or whatever is that silver box under the front storage compartment in front of the battery. Once it is disconnected then it turns on and fires right up as it should.

With this be indicative of a bad regulator or is there another reason why this would be happening?

Thanks!
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
12,881 Posts
Font Line Window Pattern Automotive exterior
to the froum
Ball Automotive lighting Vehicle registration plate Font Gas

From the Official Forum Greeter, be careful of the other imposters.
 

·
Administrator
Joined
·
18,198 Posts
Well, I think you should find out what the mystery box is so it is no longer a mystery and an educated guess could be made as to what the problem might be. Either that or just put a switch on that box and disconnect it and reconnected whenever you decide to use it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Does that silver box have cooling fins on it? If so, its the VR and it must be shorted out
Yes it does. My buddy has the same quad and confirmed it for me. He actually told me he had the exact same issue and it was the VR that caused it. Exact same situation caused it as well. So I just ordered a new OEM one to replace it
 

·
Premium Member
19’ 850SP Camo. MtAiry Maryland
Joined
·
3,319 Posts
Yes it does. My buddy has the same quad and confirmed it for me. He actually told me he had the exact same issue and it was the VR that caused it. Exact same situation caused it as well. So I just ordered a new OEM one to replace it
Oh no…if you can, cancel the OEM VR order and order a Ricks motor sports VR….it’s much higher quality made in USA…..the OEM is Chinese with a history of failing.
 
1 - 10 of 10 Posts
Top