Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I installed a 2" lift on my 2013 Polaris 850xp and I am having issues with the shock springs rubbing the sway bar on the rear. I know I can just take the sway bar off but I would like to leave it on. Does anybody have another alternative? The lift kit is an xtreme 2" lift part # XTP850. I am new here and new to Polaris so any help is appreciated!
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
1,181 Posts
I would start with the people who manufactured the lift kit. They should not be selling a kit is causing this problem. Assuming that you installed it properly, there should be no issues that require you to modify the machine. That sway bar is there for a reason and with a lift, it may be even more important.
 

·
Registered
Joined
·
16 Posts
I installed a 2" lift on my 2013 Polaris 850xp and I am having issues with the shock springs rubbing the sway bar on the rear. I know I can just take the sway bar off but I would like to leave it on. Does anybody have another alternative? The lift kit is an xtreme 2" lift part # XTP850. I am new here and new to Polaris so any help is appreciated!
Polaris changed up the sway bar some since 2009. It is more narrow than it used to be. This has caused some bikes to rub the sway bar with the shock. The sway bar can be removed without any concern. Just get used to the way the bike reacts as it will move more freely now. I have installed quite a few of these lifts myself and have had only 3 rub and all were 2013 models.

Another fix is to heat up the arm on the bar and move them away from the shocks. There is no other way to solve this problem because the sway bar is so close to the shock from the factory now.

Hope this helps you. Have a blessed day.
-Nick.
 

·
Registered
Joined
·
1,097 Posts
Welcome to the forum!
 
1 - 5 of 5 Posts
Top