Polaris ATV Forum banner

21 - 38 of 38 Posts

·
Registered
Joined
·
1 Posts
i have same thing going on with a 2016 Polaris Sportsman 110. All started after my daughter ran it out of fuel. Did you find the problem?
 

·
Registered
Joined
·
5,854 Posts
Has anyone found a definite cause of the problem? I have worked on many Chinese EFI models and they all suck! There are no service manuals and specs are sketchy at best. One I worked on at the bequest of the distributor in California: the vehicle ran fine, but would stall each time stopped or would stall when the engine was revved and then the throttle was simply closed.

Replaced the fuel pump first, injector second, throttle body third, fourth was the ECU, fifth was the battery - the solution turned out to be a valve adjustment - the distributor was making suggestions and working with the manufacturer and supplying parts, but there was no written procedure and no electronic diagnostics available outside of the factory in China where it was produced. Perhaps Polaris has some information and procedures that is not supplied by the Chinese for their Chinese manufactured products.
 

·
Registered
Joined
·
8 Posts
Found the problem... battery voltage To low.. i charge the battery with a battery tender all week end, try this morning and no more problem. I also check the charging system ..work fine 14.2v try that and let me know !
 

·
Registered
Joined
·
5,854 Posts
Try a new battery and remember the charging system does not charge below about 2500 RPM - at low speeds and at idle the battery is operating at a loss - it takes 20 minutes of riding at engine speed over 2500 RPM to replace the energy used starting the engine
 

·
Registered
Joined
·
5,854 Posts
I think I would quit flogging it and take it to a dealer - maybe the valves just need to be adjusted - just another wild guess?

It's not that hard to eliminate the fuel injection and install a carb.
 

·
Registered
Joined
·
2 Posts
Just a follow up on my issues. Don’t know if I’m out of the woods yet, but I put a new quantum fuel pump on for about $70. The atv runs great now after it is started and warms up for about 30 seconds or so. Only thing that is still weird is it has a hard time starting when cold. It usually takes 3 tries to start where it will fire up and then die. I will try and check the valves this weekend and see if that helps. Can anyone confirm that the valve lash is .002”? I don’t have a manual.
 

·
Registered
Joined
·
8 Posts
Sorry - I must have missed where it was identified as a loss of spark issue - back to troubleshooting the ignition.
How did you determine it was losing spark?

I know because i put a clear spark plug cap that i can see the spark on it.
 

·
Registered
Joined
·
5,854 Posts
Octans742 - Sorry man, you hitchhiked on this thread when you should have started a new one

So, you are having a loss of spark issue with a............ Polaris? Outlaw 50? Sportsman 110? I get confused when a thread gets muddied with like problems when most problems are not the same as the original.

Please start a new thread and you will get more precise advice.
 

·
Registered
Joined
·
8 Posts
Ok problem solved. After few test i try another battery... world fine. The old battery was not able To keep the charge at all... The charging system work fine but the battery wasen't Good. I replace the battery with other used one that i have in stock and run great!
 

·
Registered
Joined
·
6 Posts
Just a follow up on my issues. Don’t know if I’m out of the woods yet, but I put a new quantum fuel pump on for about $70. The atv runs great now after it is started and warms up for about 30 seconds or so. Only thing that is still weird is it has a hard time starting when cold. It usually takes 3 tries to start where it will fire up and then die. I will try and check the valves this weekend and see if that helps. Can anyone confirm that the valve lash is .002”? I don’t have a manual.
Where did you get the fuel pump? I'm going to try this next. My kids have stop wanting to ride it bc of this. Going to do the valves too. Anyone know the specs for the valves?
 
21 - 38 of 38 Posts
Top